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® Release History
2014-7-23 :V1.0, UM-MASSDUINO-VO1-EN
First released
2015-11-20: V2.5, UM-MASSDUINO-V2.5-EN
1, Add MD-328D Support
2, Update MassDuino HSP
® Background
Arduino is an open-source electronics prototyping platform based on flexible, easy-to-use hardware and software. It is a
very useful and applied tools. We can find many code and sharing information from internet. Arduino development
board has good scalability/ compatibility, and a wide range for application. So we can extend from the Arduino board of the
modaules alls type what we need. It's intended for artists, designers, hobbyists and anyone interested in creating interactive
objects or environments.
Arduino can be very easy to implement prototypes for the original design verification, but if you want a large-scale
commercial applications, the price of Arduino is still too high, so there very little Arduino-based commercial products on the
market.
So we released MassDuino, a new solution that is easy to use Arduino platform advantages, combined with low
manufacturing costs , making the products which is developed on Arduino platform can be mass-produced immediately,
quickly turn ideas into products.
® What's MassDuino

Massduino is a new product line, which combines the Arduino platform peripheral -rich, convenient and quick development,
low-cost and easy to manufacture large-scale production advantages. Almost all of the Arduino code can be applied to
MassDuino without modification (or very small modification), users do not need to learn any new knowledge, you can

immediately begin using MassDuino to commercial product development.

MassDuino use a special custom MCU MD-8088 and MD-328D, those chips has a very unique and new design, ensuring high

operating efficiency while providing a low cost of applications.

INHAOS upcoming a series of application modules which is based MassDuino. The application modules can be developed in
the Arduino environment, and then direct used to commercial products, creative implementation and production time

reduced to a minimum.

Make mass production with Arduino platform and chip cost <0.sUSD

1, Download Arduino 1, Development in Arduino with MassDuino 1, Deliver project with MassDuino

2, Download MassDuino HSP 2, Verfiy sketch with MassDuino UNO 2, Mass purchases MassDuino chips for

F:;”.. i

mass production
|

Project prepare Development / Prototyping Mass Production Stage
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® MassDuino Development Process
This chapter describe how to development a product with MassDuino, We assume that you have some basic knowledge of

electronic technology, and familiar with the Arduino development environment.

51, Understand what is MassDuino, the MassDuino series products are highly compatible with standard Arduino UNO R3,
So you can use MassDuino like the Arduino UNO R3.

SZ, Download MassDuino HSP (Ardunio 3rd-party Hardware Support Package for MassDuino) from www.inhaos.com , At
present the latest version of the HSP is V2.5, this version support chips is as follows:

MD-8088: 8KB Flash , 1KB SRAM, 10bit ADC

MD-328D: 32KB Flash , 2KB SRAM, 12bit ADC

MD-328D is highest compatible with the ATmgea328P, we recommended to use MD-328D, in most case the Arduino
UNO sketch can be used for MD-328P without any modification.

53, Get one UNO development board , write sketch , run and debug .
Currently we have below products:
MD-8088: MassDuino UNO R4
MD-328D: MassDuino UNO LC, MassDuino UNO LC Lite

S4, After prototype verified, do the mass production design, we provided below services:
1, We can help you do the whole product design and fabrication
2, Or you can do the design , we will help you make the prototype / pilot run / and mass production
3, Or you can buy chip from us , we can pre-programmed the chip or leave blank chip to you , with very good price

Need above service , please contact: support@inhaos.com

® MD-8088 and MD-328D specification

® Hiperformance,Low power consumption 8bit RISC ®  Hiperformance,Low power consumption 8bit RISC
MCU MCU

® 8K bytes of in-system programmable FLASH ® 32K bytes of in-system programmable FLASH

® 1K bytes SRAM on-chip ® 2K bytes SRAM on-chip

® 504 bytes of data FLASH, support byte read ® 1K bytes of data FLASH, support byte read (simulate
(simulate E2PROM) E2PROM)

® Can be edited in the Arduino environment, ® Can be edited in the Arduino environment, concise
concise and easy to use and easy to use

® Programmable synchronous / asynchronous ® Programmable synchronous / asynchronous USART
USART ® Can work in master / slave mode SPI Serial Interface

® Can work in master / slave mode SPI Serial ® Upto 30 programmable /0O
Interface ® High-performance, low -power and low-cost

® Upto30programmablel /O ® [2C -compatible two-wire serial communication

® High-performance, low -power and low-cost interface protocols , supporting master and slave

® |2C -compatible two-wire serial communication device mode
interface protocols , supporting master and slave ® 8-CH 12bit 250Ksps ADC
device mode ® 1.8to5.5V

DOC ID: UM-MASSDUINO-V2.5-EN Release Date: 2015-11-20 www.inhaos.com Page: 2 of 7


http://www.inhaos.com/�
http://www.inhaos.com/�
mailto:support@inhaos.com�

MassDuino User's manual Snwnos®

ARDUINO COMPATIBLE Everything done inhouse

® MassDuino UNO family selection guide

No Items BUONO MassDuino MassDuino MassDuino
: UNO LC UNO R4 UNO LC UNO LC Lite
1 Microcontroller ATmega328P MD-8088 MD328D MD328D
2 Operation Voltage 3.3Vor 5V 3.3Vor5Vv 3.3Vor5Vv 3.3Vor5Vv
3 Input Voltage (recommended) 7-24V 7-24V 7-24V 7-24V
- " 14 (of which 6 provide PWM 14 (of which 6 provide PWM 14 (of which 6 provide PWM 14 (of which 6 provide PWM
4 Digital 1/0 Pins
output) output) output) output)
5 Analog Input Pins 8 (A6/A7 in Extend) 8 (A6/A7 in Extend) 8 (A6/A7 in Extend) 8 (A6/A7 in Extend)
6 ADC Resolutions 10 bit 10 bit 12 bit 12 bit
32 KB 8 KB 32 KB 32 KB
7 Flash Memory of which 0.5 KB used by of which 1 KB used by of which 1 KB used by of which 1 KB used by
bootloader bootloader bootloader bootloader
8 SRAM 2KB 1KB 2KB 2KB
1KB 1KB
9 EEPROM 1KB 5048 Share with Flash Memory Share with Flash Memory
16MHz
10 Clock Speed 16MHz 16MHz 16MHz
Interface Micro USB 6Pin UART Serial Light Micro USB . o
11 (CH341) (CH341) 6Pin UART Serial Light
12 Picture
6Pin USB2Serial Light USB UART interface 6Pin USB2Serial Light
USB UART interface MD-8088 Chipset MD328D Chipset MD328D Chipset
13 Main Advantage ATmega328P Chipset Very Good cost performance 12Bit ADC 12Bit ADC
8 Good cost performance Line Regulator, low noise Very Good cost performance | Very Good cost performance
Line Regulator, low noise WILL BE PHASE OUT SOON, USB UART interface USB UART interface
NOT RECOMMEND! Ready for mass production Ready for mass production

® How to use

We released an Ardunio 3rd-party hardware package for MassDuino , so you can download it from website
(www.inhaos.com) before using it , and put it in the appropriate location , then you can use it like to use any other

Arduino board. The installation process is as follows.

stepl: Download the Arduino software from the official website and then install it on the computer.
( Surport Arduino 1.0.X and Arduino 1.5.X )

& Blink | Arduino 1.5.4 = 85 =

File Edit Sketch Tools Help

/* e
Blirk =

Turnzs on an LED on for one second, then of—

This ezample code iz in the public domain.

*/

// Pin 13 has an LED commected on most Ardui -
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step2: Download the MassDuino surport package

E Arduino - MassDuino_Support_Package

step3: Install MassDuino surport package to Arduino IDE
PS: Before do this, please make sure your Arduino IDE is closed.
Unzip the support package file, and move the two Folders (libraries and hardware) to:
C:\Users\<USERNAME>\Documents\Arduino

You can check Arduino->File->Preferences to find your support file installation directory.

@ Blink | Arduino 1.5.4 =@ =

File Edit Sketch Tools Help

/# -

?
Preferences = P |

C:\Us ers'-]]ocum ents'Arduine

Editor language: .English {English) - | (requires restart of Arduine)

Editor font size: 18 (requires restart of Arduins)

Show werbose output during: Dcompilation I:lupload

In my computer, the support package Installed here.

(o @] = |

@I\../I v| )« Local Disk (C:) » Users »-» My Documents » Arduino » r ¢f|| Search Arduino Pl
File Edit View Tools Help
Organize » Include in library * Share with Mew folder =~ [ @
=
457 Favorites MName Date modified Type Size
Bl Desktop |, hardware 2014/7/313:50 File folder
& Downloads .. libraries 2014/7/313:50 File folder
;E".l Recent Places | Install 2014/4/1516:18 Text Document 2KB
4 Libraries
[ @ Documents
[ J’ Music

step4: Connect MassDuino board to your computer with a USB-Serial adapter and USB cable.

Used standard Arduino USB2Serial Light cable to upload sketch and communication.

AT E
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® My first MassDuino sketch

1) Open the Arduino IDE. Select the board: Click Tools -> Board -> MassDuino UNO R4.0

' Y

Blink | Arduino 1.5.4 =S
ol34

File Edit SketcH [Tools) [Hefimmmm | 1

Auto Format Ctrl+T
Archive Sketch

Blink Fix Encoding & Reload
Serial Monitor Ctrl+Shift+M m
/f Pin 13 ll‘ Board 3 I_c 2 |oards
A ogive it Tort v Arcliind o
i = Arduino Uno
int led 1 Programmer 2
Arduino Duemilanove or Diecimila
Burn Bootloader
Arduino Nano

/7 the setup routine runs once when vou Arduino Mega 2560 or Mega ADK

vold setup () { Arduino Mega (ATmegal280)
// initialize the digital pin as an ol Arduino Leonardo
pintode (led, OUTPUT); Arduine Micro
} Arduino Esplora
Arduino Mini
Arduino Ethernet
/7 the loop routine runs over and over 3 Arduine Fio
wold loop() { Arduino BT
- . LilyPad Arduino USB
digitalWrite{led, HICH); // turn thg e E level)

. LilyPad Arduino
delay (1000) : // wait for Arduino Pro or Pro Mini

digitalWirite (led, LOW); /7 turn the  Arduino NG or older hze LOW

delay (1000) : // wait foy Arduino Robot Control
1 Arduino Robot Motor

Arduino ARM (32-bits) Boards

Arduino Due (Programming Port)
Arduino Due (Native USB Port)

PO PV o

© | MassDuino UNO R4.0 <= 3

2)  Select the COM: Click Tools -> Serial Port -> COM4(which connected with MassDuino.)

g N

Blink | Arduino 1.5.4 [ES I
o141

File Edit Sketch| [Tools | <imm | 4

Auto Format Ctrl+T
Archive Sketch
Fix Encoding & Reload

*/ Serial Monitor Ctrl+Shift+M i
Eoaed 3
5 > | Port > cOMa _=1rds.
; ; v coms | <
77 give it Programmer M 6 AN
int led = 1 Burn Bootloader

DOC ID: UM-MASSDUINO-V2.5-EN Release Date: 2015-11-20 www.inhaos.com Page: 5 of 7


http://www.inhaos.com/�

MassDuino User's manual Yinmaose

ARDUINO CONPATIBLE Everything done inhouse

3) step6: An example of program: Click File -> Examples -> which you want.

f €3 Blink | Arduino 1.5.4 9 =RECIE X 1
7 | — tdit Sketch Tools Help
New Ctrl+MN
Open... Ctrl+0O
Sketchbaol 3 AnalogReadSerial
8 - Examples 3 Digia Savallinimum
Close CIrl+ 03.Analog 3 Blink G| 10
Save Ctrl+5 04.Communication » DigitalReadSenal
Save As.. Ctrl+5hift+5 05.Control 2 Fade
Upload Ctrl+U 06.Sensors 3 ReadAnalogVoltage
Upload Using Programmer  Ctrl+Shift+U 07.Display =i
Page Setup Ctrl+Shift+P 08.Strings ’
Print Ctrl+P 09.Us8 . ’
10.5tarterkit 3
Preferences Cirl+Comma ArduinoISP
Quit Cirl+Q DallasTemperature »
Enerlib 3
// the loop routine runs over s Ethernet ) WEL
vold loop l[) { SRO4_Example
4) step7: Upload the blink example to MassDuino.
(@ Blink | Arduino 1.5.4 o] B |

File Edit Sketch Tools Help

Elink &
// Pin 12 has an LED comnected on most fArduino boards. g
// give it a name:

int led = 13;

// the setup routine runs once when yvou press reset:
void setup() {
// initialize the digital pin as an output.
pirMode {(led, OUTFUT) ;

// the loop routine runs over and over again forever:
void loop() {
digitalWrite(led, HICH): // twrn the LED on (HIGH is the woltage level)

delay (1000) ; // wait for a second
digitalWrite(led, LOW); // twrn the LED off by making the voltage LOW
delay (1000) ; // wait for a second

5) Now you can see the LED is blinking according to the arduino code.
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53. 34
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You can choose the
size of the
voltage by jumper
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® Contact us
1111 Oakmont Drive #C, San Jose, CA 95117

www.inhaos.com

Tel No: +1-408-981-6615

E-mail: support@inhaos.com
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